At Angel Solutions we take the security of your data very seriously and continually strive to stay ahead of the latest security threats. The most recent of these is called 'Poodle' and may affect you if you are using an old internet browser.

Unfortunately, due the complex nature of this threat and the vulnerabilities of older browsers, we have had to disable all of our products within old versions of Internet Explorer (version 6 or before). This means that if you currently use Internet Explorer 6 or earlier, you will not be able to log in to Perspective until you update your browser.

Regrettably this was the only available option. If this affects you, please be aware that the browser you are using is now over 13 years old. We request that you update to a more secure browser as soon as possible. This will not cost you anything and is easy to do.

Here is a list of more secure and up-to-date internet browsers:

You can read about the security threat in more detail here

Thank you for using Perspective and be assured that we will continue to keep your data safe.